SI2010 Getting Started with PyRx

From NBCRwiki

Jump to: navigation, search

Back to Track 4

Please visit PyRx website to download PyRx, watch Screencasts and get up-to-date information about latest releases.

Before we start, make sure that you have the latest version of PyRx installed.

After installation is complete, start PyRx using PyRx_icon.png shortcut icon from your Desktop (Windows/Linux) or from your Applications folder (Mac).

Load/Import Molecule

Use File -> Import menu, select Molecule From Web and click on Next button. Enter 2BAT for PDB ID and click finish. I have found this protein searching Neuraminidase on DrugBank. It's linked as Experimental PDB ID for Relenza. Using PyRx, expand 2bat tree in Molecules tab under Navigator pane to see all residues in this protein. Select Documents tab under View pane and click on Open icon (second icon on toolbar). Navigate to ~/.mgltools/PyRx/PDB folder and open 2bat.pdb. Scroll down and find lines corresponding to sialic acid (SIA):

HETATM 3216  C1  SIA A 600      90.065  93.354  66.572  1.00 27.73           C  
...
HETATM 3236  O10 SIA A 600      94.520  88.509  65.057  1.00 21.85           O

Preparing Ligand for AutoDock

Create a new document by clicking on the first icon on the toolbar; copy/paste SIA residues in the newly created document and save it as, say, SialicAcid.pdb. Open SialicAcid.pdb using File -> 'Load Molecule'. Right-click (control-click on Mac) on SialicAcid entry under Molecules tab and click on AutoDock -> Make Ligand menu. This creates pdbqt file under Ligands folder in AutoDock tab.

Preparing Macromolecule

With 2bat.pdb tab selected under Documents, remove all HETATM records from this file and save it. Select 2bat under Molecules tab, right-click on it and select Remove; we'll be reading our modified molecule instead. Open File menu and select 2bat.pdb from the list of recent files. Under Molecules tab select 2bat again; right-click on it and this time click on AutoDock -> Make Macromolecule menu. This creates 2bat folder under Macromolecules in AutoDock tab where it stores 2bat.pdbqt.

Run AutoGrid

Now that we have our input files ready, click on Start button on the first page of AutoDock Wizard. Select SialicAcid.pdbqt in Navigator -> AutoDock -> Ligand and click Forward. Select 2bat under Macromolecules folder and click on Forward again. You'll be taken to Run AutoGrid page where you can see a cube outlining boundaries of the grid. Move the handles on this grid to make it large enough to include the site where sialic acid is bound. Click on Forward to start AutoGrid computations.

Run AutoDock

Notice that you can select among four different docking algorithms on this page. For each of these algorithms users can click on Docking Parameters button to modify the defaults. My computation with these defaults took around 20 minutes to complete so, for the purpose of this demo, lets make shorter runs instead. With the "Lamarckian GA" selected click on Docking Parameters button. Under Genetic Algorithm Parameters locate Maximum number of energy evaluations: and change it from medium (2500000) to short (250000). Click on Forward button to start AutoDock computations.

Analyze Results

When AutoDock jobs are finished you'll be taken to Analyze Results page that contains a table of docking results. Each row in this table represents a binding mode predicted by AutoDock and you can click on these rows to display corresponding result in a 3D Scene. You can also use arrow keys to navigate this table. Right-click on any of the rows and you'll see Create Clustering Histogram menu. Click on it to make a matplotlib plot for clustering. You'll be able to click on any bars on this 2D plot to highlight corresponding conformation in the table and update 3D Scene accordingly.

Energy Minimization

PyRx includes Open Babel widget under Controls pane that can be used to create input pdbqt files for Virtual Screening. Lets go to PubChem and search for Neuraminidase. PubChem currently contains records for Tamiflu and Relenza similar to our DrugBank search. We'll download 2D and 3D records and discuss how to use Open Babel energy minimizer to convert 2D molecules into 3D. PyRx also allows you to use two different versions of Gasteiger-Marsili partial charges. Use Edit -> Preferences... menu; expand Open Babel and select AutoDock Ligand. You'll be able to select either PyBabel (MGLTools) or Open Babel partial charges. When creating pdbqt ligands with Open Babel widget PyRx uses this option for partial charges (PyBabel (MGLTools) is the default).

Docking Tables

Finally we'll discuss Tables menu under View pane. This widget displays tables stored in SQLite database. Each time we make a ligand or macromolecule, PyRx creates a row in corresponding table with information that can be accessed later on. Entries in Docking Results are created when PyRx reads Docking Log File (DLG). When PyRx starts it read this database and populates Tables with the entries from the database. This provide a birds eye view of docking results that you can come back later. You can also use third party SQLite editors to work with this database. PyRx database is located in ~/.mgltools/PyRx/db.sqlite3.

Back to Track 4

Personal tools